Автоматизация учета труда и заработной платы


ФЕДЕРАЛЬНОЕ ГОСУДАРСТВЕННОЕ АВТОНОМНОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

БЕЛГОРОДСКИЙ ГОСУДАРСТВЕННЫЙ НАЦИОНАЛЬНЫЙ

ИССЛЕДОВАТЕЛЬСКИЙ УНИВЕРСИТЕТ

(НИУ «БелГУ»)

ФАКУЛЬТЕТ КОМПЬЮТЕРНЫХ НАУК И ТЕЛЕКОММУНИКАЦИЙ

КАФЕДРА ПРИКЛАДНОЙ ИНФОРМАТИКИ

Курсовая работа

Автоматизация учета труда и заработной платы

Студента очного отделения

4 курса 1400000000 группы

Япринцева Евгения Александровича

Научный руководитель

ассистент Зайцева Татьяна Валентиновна

БЕЛГОРОД 2014

  • Введение
  • Современное учебное заведение — это находящаяся в постоянном развитии, динамическая система со сложными иерархическими организационно-управленческими структурами и подразделениями. Достижение стоящих перед вузом стратегических целей может осуществляться путем разработки и внедрения информационной системы управления учебным заведением, либо его подразделениями. Информационная система должна позволять решать ряд задач по сбору, учету, хранению, контролю, обработке и анализу информации об основных процессах высшего учебного заведения.
  • Автоматизация системы управления остается актуальной задачей для большинства вузов. В настоящее время предлагаются различные решения в этой сфере и в то же время создание универсальной полномасштабной ERP-системы для высшего профессионального образования только декларируется.
  • Информационные системы и технологии становятся средством повышения эффективности и производительности работы человека, позволяют быстро и качественно анализировать информацию, принимать правильные решения. К подобным системам относится и платформа «1С: Предприятие» фирмы «1С».
  • «1С: Предприятие» является универсальной системой автоматизации деятельности предприятий и организаций. За счет своей универсальности система может быть использована для автоматизации самых различных участков деятельности предприятий и организаций, в том числе и деятельности факультетов.
  • Данная курсовая работа направлена на изучение теоретических основ и их реализации на практике посредством разработки автоматизированной системы учета успеваемости студентов факультета компьютерных наук и телекоммуникаций НИУ «БелГУ».
  • Цель работы — создать конфигурацию, обеспечивающую эффективно-организованный документооборот и реализующую следующие функции:
  • · ведение учета студентов;
  • · формирование всевозможных документов в работе деканата, и на основе этих документов, создание разнообразных отчетов;
  • · организация быстрого и удобного ввода документов и вывода отчетов на печать.
  • Гипотеза курсовой работы: если в работу деканата будет внедрено программное средство автоматизации учета успеваемости, то можно предположить что оно будет способствовать эффективности системы управления, и облегчит работу сотрудников деканата.
  • Цель и гипотеза определили следующие задачи:
  • · изучение специальной литературы по вопросу предметной области;
  • · проектирование структуры конфигурации;
  • · реализация конфигурации на платформе «1С: Предприятие 8».
  • Данная курсовая работа состоит из введения, четырех разделов, заключения, списка использованной литературы.

1. Обследование предметной области

1.1 Обзор предметной области

Факультет компьютерных наук и телекоммуникаций был основан 26 августа 2002 г. Первоначально на факультете подготовка велась по трем специальностям — «Математическое обеспечение и администрирование информационных систем», «Прикладная информатика в экономике» и «Сети связи и системы коммутации». В 2005 году спектр специальностей был расширен за счет специальности «Радиосвязь, радиовещание и телевидение».

Специальности и направления обучения факультета компьютерных наук и телекоммуникаций в полной мере отвечают потребностям реализации информационных процессов на современном уровне, включая процессы получения знаний (научные исследования), использования знаний (образование, создание новых технологий, управление и др.), обмена знаниями и другими сведениями. Специалисты по компьютерным наукам и информационным технологиям в настоящее время являются самыми востребованными на рынке труда.

На настоящий момент на факультете осуществляется подготовка по 4 специальностям высшего профессионального образования и обучается около 1700 студентов на всех формах обучения, включая заочную форму обучения и слушателей второго высшего образования.

Одной из основных и трудоемких в работе факультета является деятельность деканата. Работникам деканата приходится выполнять огромный объем рутинной работы по учету контингента студентов, обеспечению учебного процесса, предоставлению информации в различные подразделения вуза. При этом всю информацию необходимо представлять в различных форматах.

Необходимость внедрения информационной системы, автоматизирующей основные функции образовательного процесса очевидна.

1.2 Автоматизация деятельности вузов

Глобальное внедрение компьютерных технологий во все сферы деятельности, формирование новых коммуникаций и высокоавтоматизированной информационной среды стали началом преобразования традиционной системы образования. В настоящее время ни одно учебно-образовательное заведение не обходится без использования информационных компьютерных технологий, как в учебной деятельности, так и в управлении.

Современное, эффективное управление вузом возможно только на основе автоматизированных информационных систем (АИС).

В большинстве случаев автоматизация деятельности деканата носит достаточно бессистемный, случайный характер. В деканатах существуют множество разрозненных систем, каждая из которых решает только узкие задачи, причем в большинстве случаев в эти задачи сводятся к вводу и поддержании всей информации в системе в актуальном состоянии полностью вручную и просто выводу печатных форм. Отсутствует единая технология обработки и представления данных.

Возникает проблема адаптирования готового лицензированного программного продукта для работы конкретного вуза (в частности для факультетов). К тому же, в большинстве разработанных программных продуктов отсутствует возможность исправления форм отчетов, справок и других документов. Но даже, если такая функция имеется, то достаточно проблематично будет исправить программный код для нужд конкретного деканата.

Разработок в области автоматизации процессов, протекающих в вузах, существует немало. Однако среди них нет систем, явно лидирующих на рынке и позволяющих решать на основе единого подхода весь комплекс задач вуза. Поэтому вуз может пытаться внедрить существующие решения или вести самостоятельную разработку. При этом вуз будет вынужден либо постоянно привлекать внешние фирмы, либо опираться на развитие собственных служб информационных технологий и инфраструктуры. Последнее предпочтительнее и обеспечивает стабильное и поступательное развитие.

Анализ тенденций развития АИС вузов показывает, что в ближайшее время на рынок выйдут типовые решения, предназначенные для построения глобальных АИС вуза основанные на различных программных платформах.

Одним среди таковых будет система, построенная на платформе «1С: Предприятие», перспективность и популярность которой не вызывает сомнений.

К данному выводу приводит ряд фактов. Рассматривая, прототипы интегрированных АИС вузов видно, что в них закладывается обмен данными с типовыми решениями «1С: Предприятие». Данная ситуация не случайна, так как большинство вузов в первую очередь автоматизируют финансово-хозяйственную деятельность и это производится, как правило, на типовых конфигурациях «1С: Предприятие». Потребности в автоматизации управления учебным процессом, электронного обучения, документооборота, библиотек и др. рассматриваются во вторую и последующую очередь. Для этих целей могут применяться различные системы, рациональное функционирование которых, рано или поздно потребует обмена данными с решениями «1С». Поэтому всегда будет высок интерес к построению интегрированной системы на одной платформе «1С: Предприятие».

Тенденции развития решений подобного рода принимают практически массовый характер (АИС Бийского технологического института [1], АИС Ивановского государственного университета [2], множество мелких систем автоматизации отдельных подразделений, самостоятельно развиваемые вузами).

Над решениями автоматизации вузовской деятельности на платформе «1С: Предприятие» работает как фирма «1С», так и достаточно большое количество известных разработчиков АВРО-БУС, Инфосьют-Софт, Комкон-Проект, ХроноГраф и др. Преимуществом данных решений является их относительная дешевизна и возможность поддержки специалистами фирм франчайзи, широко распространенными в стране, а зачастую и полностью самостоятельными силами вуза.

Особое место в сотрудничестве с вузами необходимо отвести фирме «1С» продвигающей в сфере образования целый комплекс инициатив. Эффективное взаимодействие вуза с фирмой «1С» позволит сэкономить значительные средства на программном обеспечении (ПО), закупаемом как для целей автоматизации деятельности подразделений, так и для образовательного процесса. Фирма имеет льготные цены на ПО для образования в десятки, а по отдельным позициям и в сотни раз ниже обычных (для бизнес-организаций). [4]

Особо хочется отметить, что помимо внедрения информационных технологий, следует наладить обучение и консультирование преподавателей, научных работников, служащих вуза. Не менее важным является обеспечение формирования информационных ресурсов системы. Эти задачи возникают в полном масштабе в вузах с активно развивающейся АИС и также потребуют ощутимых ресурсов.

Таким образом, системный и продуманный подход позволит практически любому вузу (или его подразделению) продвигаться к построению интегрированной автоматизированной информационной системы на основе «1С: Предприятие 8».

компьютерный конфигурация предприятие учет

2. Проектирование информационной системы

2.1 Анализ бизнес-процессов

Проектирование информационной системы начнем с рассмотрения бизнес — процессов. Разработанная модель представляет процесс как совокупность функциональных блоков соединенных интерфейсными дугами. Функциональный блок — действие, выраженное глагольным оборотом, интерфейсная дуга — предмет, описанный существительным с уточняющей информацией. В зависимости от места соединения дуги с блоком различают входы (слева), выходы (справа), управление (сверху), механизмы или ресурсы (снизу). Любое действие может быть декомпозировано — разложено на более мелкие, которые, в свою очередь могут быть декомпозированы, и т. д. до уровня разумной достаточности. Назначение разработанной модели — выявить процессы, нуждающиеся в автоматизации.

Рассмотрим процесс построения модели. Контекстная диаграмма (диаграмма A-0) разрабатываемой системы приведена на рисунке 1.

Рис. 1. Контекстная диаграмма (IDEF0)

Первый уровень описывает задачу в целом. Необходимо отметить, что его важность заключается в том, что на нем мы определяем две принципиальные характеристики модели точка зрения и цель.

· Точка зрения: Деканат.

· Цель: Выявление последовательности и взаимосвязи операций процесса учета успеваемости студентов.

Теперь разобьем задачу на более мелкие составляющие — этапы. Детализация контекстной диаграммы A-0 в нотации IDEF0 представлена на рисунке 2.

Рис. 2. Декомпозиция контекстной диаграммы (IDEF0)

Из диаграммы видна последовательность и взаимосвязь этапов. Легко увидеть, что не все этапы могут быть автоматизированы, а только лишь 3 из них. Таким образом, был проведен анализ бизнес-процессов деятельности деканата по учету успеваемости студентов.

2.2 Проектирование конфигурации

Проектируемая система будет в дальнейшем разрабатываться на платформе «1С: Предприятие 8.0», которая представляет собой совокупность механизмов, предназначенных для манипулирования различными типами объектов предметной области. Конкретный набор объектов, структуры информационных массивов, алгоритмы обработки информации определяет конкретная конфигурация. Вместе с конфигурацией система «1С: Предприятие» выступает в качестве уже готового к использованию программного продукта. [3]

Согласно логике выбранной платформы для автоматизации процессов, рассмотренных в главе 2.1 можно выделить ряд объектов конфигурации, представленный в таблице 1.

Таблица №1. Объекты проектируемой системы

Типы объектов Объекты
Справочники Сотрудники
Группы
РазновидностьТруда
Преподаватели
Специальности
ГодыОбучения
Документы ЭкзаменационнаяВедомость
ВедомостьКурсовыхРабот
ЗачетнаяВедомость
ВводАкадемРазницы
Журнал документов ЖурналВедомостей
Константы Вуз
ВузСокр
Факультет
Декан
Перечисления Оценки
ПолСтудента
Семестр
ФормаКонторля
ФормаОбучения
Регистр сведений Успеваемость
Типы объектов Объекты
Отчеты ЗадолженностиПоЗП
ЗадолженностиПоГруппе
УспеваемостьГруппы
АкадемическаяСправка

Справочник «Студенты» служит для хранения информации обо всех студентах факультета. Иерархический справочник «Группы» хранит информацию о группах с разделением их на курсы. Справочник «Преподаватели» служит для хранения информации обо всех преподавателях. Справочник «Дисциплины» содержит перечень всех дисциплин, которые преподаются студентам.

Документы предназначены для фиксации и хранения информации о произошедших событиях и операциях, которые имеют отношение к автоматизируемой предметной области.

Документы «Экзаменационная ведомость», «Ведомость курсовых работ» и «Зачетная ведомость» объединены в журнале документов «Журнал ведомостей». Документ «Ввод академической разницы» предназначен для отражения текущей успеваемости нового студента (например, перешедшего с другого факультета).

Объект конфигурации «Отчет» является прикладным объектом и предназначен для описания средств и алгоритмов, при помощи которых пользователь сможет получать необходимые ему выходные данные.

При разработке конфигурации было принято решение создать несколько отчетов, которые будут отражать задолженности, успеваемость групп и др.

3. Разработка информационной системы

3.1 Создание объектов типа «Константа» и «Перечисление»

Для работы с постоянной и условно постоянной информацией, имеющей единственное значение, в конфигурации предусмотрен объект «Константа». Создание определенных ранее констант выполняется путем внесения в свойства вновь созданного объекта таких данных, как имя, синоним и тип. В конфигурации были созданы четыре константы. На рисунке 3 представлены все созданные константы.

Рис. 3. Перечень созданных констант

Объект «Перечисление» является частью глобального контекста программы «1С: Предприятие». Этот объект в качестве своих атрибутов имеет значения объектов конкретных видов перечислений, заданных в конфигурации.

Перечисление «Оценки» содержит набор всех возможных значений оценок полученных на экзаменах и зачетах: отлично, зачтено, недопуск и т. д. На рисунке 4 представлен результат создания данного перечисления в режиме конфигурации.

Рис. 4. Перечисление «Оценки»

В отношении форм контроля успеваемости имеются несколько вариантов. Для их хранения создано перечисление «ФормаКонтроля». Результат представлен на рисунке 5.

Рис. 5. Перечисление «ФормаКонтроля»

При разработке конфигурации были созданы пять перечислений, которые представлены на рисунке 5.

Рис. 6. Список созданных перечислений

3.2 Создание объектов типа «Справочник»

Справочники предназначены для хранения сведений о множестве однотипных объектов, которые используются при ведении аналитического учета и для заполнения документов.

Создадим справочник с именем «Специальности» для хранения списка специальностей факультета. На вкладке «Данные» укажем длину наименования — 70 символов и длину кода — 3 символа. Определим, что справочник будет содержать реквизит «ГосНомер». На вкладке «Формы» указали, что редактирование и выбор элементов справочника будет производиться обоими способами (рисунок 7).

Рис. 7. Справочник «Специальности»

Также необходимо создать справочник «Группы» для хранения информации о группах с разбивкой по курсам. На вкладке «Иерархия» указали, что справочник будет иерархическим и ограничили его двумя уровнями иерархии (рисунок 8). На вкладке «Данные» создали реквизит «Специальность» и указали тип «СправочникСсылка. Специальности».

Рис. 8. Справочник «Группы»

Далее создали наш самый главный справочник «Студенты». На вкладке «Данные» указали длину наименования 70 символов и добавили реквизиты:

· «ПолСтудента», тип — «ПеречислениеСсылка. ПолСтудента»;

· «Группа», тип — «СправочникСсылка. Группы»;

· «НомерЗачКнижки», тип — «Строка», длинна — 7;

· «ФормаОбучения», тип — «ПеречислениеСсылка. ФормаОбучения»;

· «ДатаРождения», тип — «Дата».

На вкладке «Формы» указали, что редактирование элементов справочника будет производиться в диалоге, а выбор — обоими способами. Настроили внешний вид формы «ФормаЭлемента» (рисунок 9).

Рис. 9. «ФормаЭлемента» справочника «Студенты»

При разработке конфигурации были созданы шесть справочников, которые представлены на рисунке 10.

Рис. 10. Список созданных справочников

Запустим «1С: Предприятие» в режиме отладки и заполним разработанные справочники. На рисунке 11 продемонстрирован пример заполнения справочника «Студенты».

Рис. 11. Заполнение справочника «Студенты»

3.3 Создание объектов типа «Регистр сведений», «Документ» и «Журнал документов»

Объект конфигурации «Регистр сведений» является прикладным объектом и предназначен для описания структуры хранения данных в разрезе нескольких измерений. При создании регистра сведений «Успеваемость» на закладке «Основные» задали имя регистра и его периодичность: «Непериодический», а на закладке «Данные» определили измерения и ресурсы данного регистра (рисунок 12).

Рис. 12. Регистр сведений «Успеваемость»

Документы предназначены для отражения хозяйственных событий, которые имеют отношение к автоматизируемой предметной области. Все документы характеризуются номером и датой. Каждый документ может иметь неограниченное количество реквизитов и табличных частей, которые задаются на закладке «Данные» окна редактирования объекта. В разрабатываемой системе предполагаются четыре документа (рисунок 13).

Рис. 13. Список созданных документов

Так же для документа создаются формы ввода — экранные аналоги реальных документов. Рассмотрим их создание более подробно.

Документ «Экзаменационная ведомость» имеет одну табличную часть и несколько реквизитов. Форма данного документа представлена на рисунке 14.

Рис. 14. Форма документа «Экзаменационная ведомость»

Для автоматического заполнения табличной части при выборе группы впишем в модуль формы следующую процедуру:

Процедура ГруппаПриИзменении(Элемент)

ДокументОбъект. ТабличнаяЧасть1.Очистить();

Запрос = Новый Запрос;

Запрос. УстановитьПараметр(«Группа»,ДокументОбъект. Группа);

ТекстЗапроса = «ВЫБРАТЬ

| Студенты. Ссылка, Студенты. НомерЗачКнижки

| ИЗ Справочник. Студенты КАК Студенты

| ГДЕ Студенты. Группа = &Группа»;

Запрос. Текст = ТекстЗапроса;

ВыборкаРезультата = Запрос. Выполнить().Выбрать();

Пока ВыборкаРезультата. Следующий()

Цикл

НовСтр = ДокументОбъект. ТабличнаяЧасть1.Добавить();

НовСтр. ФИОСтудента = ВыборкаРезультата. Ссылка;

НовСтр. НомерЗачКнижки = ВыборкаРезультата. НомерЗачКнижки;

КонецЦикла

КонецПроцедуры

На форме также расположена кнопка «Печать», при нажатии на которую из модуля объекта вызывается процедура. Данная процедура формирует макет. Текст процедуры, а также печатная форма приведены в приложении 1.

На закладке «Движения» документа «Экзаменационная деятельность» необходимо создать процедуру проведения документа по регистру сведений «Успеваемость». Это можно сделать с помощью конструктора движения, который вызывается из диалогового окна редактирования документа. Окно конструктора движения представлено на рисунке 15.

Рис. 15. Окно конструктора движения для документа «Экзаменационная ведомость»

Конструктор движения автоматически формирует текст процедуры обработки проведения и записывает ее в модуль документа. Текст данной процедуры приведен в приложении 2.

По аналогии с документом «Экзаменационная ведомость» создаются документы: «Ведомость курсовых работ» и «Зачетная ведомость». Печатные формы этих документов приведены в приложении 1.

Документ «Ввод академической разницы» создает записи в регистре сведений «Успеваемость», но не имеет печатной формы (рисунок 16).

Рис. 16. Форма документа «Ввод академической разницы»

Текст процедур обработки проведения всех документов приведен в приложении 2.

Журнал документов — это прикладной объект конфигурации, который предназначен для просмотра документов разных видов.

Журнал документов «Журнал ведомостей» объединил три вида документов: «Экзаменационная ведомость», «Ведомость курсовых работ» и «Зачетная ведомость» (рисунок 17).

Рис. 17. Журнал документов «Журнал ведомостей»

3.4 Создание объектов типа «Отчет»

Прикладной объект конфигурации «Отчет» необходим для предоставления информации из базы данных в печатном виде.

Отчеты создаются с помощью конструктора выходных форм, который вызывается из окна редактирования объекта «Отчет».

Рассмотрим подробнее отчет «Задолженности по факультету». Этот отчет выводит список задолженностей с группировкой по группам и студентам. В качестве источника данных для запроса выступают данные из регистра сведений «Успеваемость». Данный отчет выводится в табличный документ, используя построитель отчетов. Выбранное оформление — «Трава» (рисунок 18).

Рис. 18. Отчет «Задолженности по факультету»

По аналогии с отчетом «Задолженности по факультету» создается отчет «Задолженности по группе».

Отчет «Успеваемость группы» выводится в круговую диаграмму, где в качестве серий выступают различные оценки выбранной группы, выбранной формы контроля (например, экзамены), а также выбранный семестр. Данные диаграммы отображаются в процентах (рисунок 19).

Рис. 19. Отчет «Успеваемость группы»

Отчет «Академическая справка» формирует весь список сданных дисциплин по выбранному студенту (рисунок 20).

Рис. 20. Отчет «Академическая справка»

Всего в данной конфигурации было создано четыре отчета (рисунок 21).

Рис. 21. Список созданных отчетов

3.5 Создание объектов типа « Интерфейс » и «Стиль»

Для эффективной работы каждого пользователя может быть создан индивидуальный пользовательский интерфейс. С помощью конструктора меню создали панель интерфейса «Главное меню». Откорректировали эту панель и добавили иконки (рисунок 22).

Рис. 22. Интерфейс «Основной»

Стили представляют собой элементы прикладного решения, описывающие цвет формы, фон кнопки, цвет текста в поле ввода и т. д. Создали стиль «Главный», который представлен на рисунке 23.

Рис. 23. Стиль «Главный»

Указали, что интерфейс «Основной» и стиль «Главный» будут использоваться по умолчанию для конфигурации «Учет успеваемости студентов». На этом разработка конфигурации завершена.

4. Руководство пользователя

Для того чтобы освоить приложение можно было без помощи создателя или профессионалов 1С, для приложения составляется руководство пользователя.

4.1 Порядок работы с конфигурацией

Для работы с конфигурацией «Учет успеваемости студентов» требуются знания в области работы с автоматизированными системами и опыт работы с программным продуктами «1С». Но основным, конечно же, является знание деятельности деканата. Реализованная конфигурация максимально упрощает работу сотрудников деканата.

Любой пользователь сможет очень легко и быстро освоить данную конфигурацию, если обладает перечисленными выше навыками. Более того, пользователь заметит простоту и достаточность данной конфигурации.

Запускается данная конфигурация через приложение «1С: Предприятие 8». Для добавления пользователей и изменения конфигурации используется режим «Конфигуратор», а для работы с самой конфигурацией (выполнение соответствующих операций, составление документов и формирование отчетов) используется режим «1С: Предприятие».

4.2. Пример заполнения конфигурации данными

Заполнение данными происходит в режиме «1С: Предприятие». В первую очередь требуется заполнить константы и справочники. Заполнение констант представлено на рисунке 24.

Рис. 24. Константы

Далее требуется заполнить справочники, такие как:

· Справочник «Специальности» (рисунок 25);

Рис. 25. Справочник «Специальности»

· Справочник «Дисциплины» (рисунок 26);

Рис. 26. Справочник «Дисциплины»

· Справочник «Преподаватели» (рисунок 27);

Рис. 27. Справочник «Дисциплины»

· Справочник «Годы обучения».

Затем заполняется справочник «Группы». В-первую очередь требуется заполнить иерархию первого уровня — создать группы курсов (например, 1 курс), и только после этого вносить информацию о группах студентов.

Самым последним заполняется справочник «Студенты». Для каждого студента обязательно требуется указать номер его группы, номер зачетной книжки, форму обучения и т. д.

Для проведения документа требуется заполнить все его реквизиты. Для примера приведем заполнение документа «Зачетная ведомость» (рисунок 28).

Рис. 28. Документ «Зачетная ведомость»

Пример заполнения документа «Ввод академической разницы» представлен на рисунке 29.

Рис. 29. Документ «Ввод академической разницы»

4.3 Рекомендации по обучению работе с конфигурацией

Для работы с данной конфигурацией достаточно навыков работы со стандартными конфигурациями «1С: Предприятие 8», методика обучения предлагается схожая и подразумевает наличие у обучаемого минимальных знаний в области учебной деятельности вуза.

Обучающий должен быть знаком с конфигурацией и уметь передать свои знания и навыки обучаемому.

Для пользователей хотя бы немного знакомых с системами «1С» изучение данной конфигурации не составит большого труда. Конфигурация «Учет успеваемости студентов» достаточно проста, а интерфейс эргономичен и удобен.

Заключение

В процессе выполнения курсовой работы была подробно рассмотрена предметная область — деятельность деканата, в частности по учету успеваемости студентов. Был выявлен ряд особенностей в деятельности работников деканата, на основании которых была обоснована необходимость в автоматизации этой деятельности. Итогом работы явилось проектирование и разработка автоматизированной системы учета успеваемости студентов факультета Компьютерных наук и телекоммуникаций НИУ «БелГУ».

Во-первых, были детально изучены существующие объекты конфигурации в системе «1С: Предприятие». Во-вторых, была непосредственно разработана автоматизированная система учета успеваемости студентов. Разработка велась на основе платформы «1С: Предприятие» фирмы «1С» с использованием различных возможностей этой платформы.

В результате выполнения курсовой работы были приобретены навыки и умения проектирования и разработки конфигурации для конкретной предметной области, разработки интерфейса пользователя, использования различных средств и возможностей платформы «1С: Предприятие». Полученные знания позволят без особых проблем проектировать более сложные системы или совершенствовать существующие.

Список использованной литературы

1. Ратманова И. Д. Подход к организации информационной поддержки управления вузом. Информационные технологии в обеспечении нового качества высшего образования. Сборник научных статей. Книга 3 / Труды Всероссийской научно-практической конференции с международным участием «Информационные технологии в обеспечении нового качества высшего образования (14-15 апреля 2010 г., Москва, НИТУ «МИСиС»)». — М.: Исследовательский центр проблем качества подготовки специалистов НИТУ «МИСиС», 133. — 135 с.

2. Радченко М. Г. 1С: Предприятие 8.0. Практическое пособие разработчика. Примеры и типовые приемы.- М.: ООО «1С-Паблишинг», 2004.- 656 с., ил.

Приложение 1

Текст процедуры «Печать» формы документа «Экзаменационная ведомость»

Процедура Печать(Элемент)

//{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(Печать)

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

ТабДок = Новый ТабличныйДокумент;

Макет = Документы. ЭкзаменационнаяВедомость. ПолучитьМакет(«Печать»);

//Главная

Область = Макет. ПолучитьОбласть(«Главная»);

// Подготовить область для вывода рисунка картинки в табличный документ

Рисунок = Область. Рисунки. Добавить(ТипРисункаТабличногоДокумента. Картинка);

Рисунок. Картинка = БиблиотекаКартинок. Герб;

Рисунок. РазмерКартинки = РазмерКартинки. АвтоРазмер;

Рисунок. ЦветЛинии = Новый Цвет(255, 255, 255);

Область. Параметры. Вуз = Константы. Вуз. Получить();

Область. Параметры. ВузСокр = Константы. ВузСокр. Получить();

Область. Параметры. Факультет = Константы. Факультет. Получить();

ТабДок. Вывести(Область);

// Заголовок

Область = Макет. ПолучитьОбласть(«Заголовок»);

ТабДок. Вывести(Область);

// Шапка

Область = Макет. ПолучитьОбласть(«Шапка»);

Область. Параметры. Дата = Дата;

Область. Параметры. Семестр = Семестр;

Область. Параметры. Год = Год;

Область. Параметры. Группа = Группа;

Область. Параметры. Дисциплина = Дисциплина;

Область. Параметры. Преподаватель = Преподаватель;

ТабДок. Вывести(Область);

// ТабличнаяЧасть1

Область = Макет. ПолучитьОбласть(«ТабличнаяЧасть1Шапка»);

ТабДок. Вывести(Область);

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл

Область = Макет. ПолучитьОбласть(«ТабличнаяЧасть1»);

Область. Параметры. Номер = ТекСтрокаТабличнаяЧасть1.НомерСтроки;

Область. Параметры. ФИОСтудента = ТекСтрокаТабличнаяЧасть1.ФИОСтудента;

Область. Параметры. НомерЗачКнижки = ТекСтрокаТабличнаяЧасть1.НомерЗачКнижки;

Область. Параметры. Оценка = ТекСтрокаТабличнаяЧасть1.Оценка;

ТабДок. Вывести(Область);

КонецЦикла;

// Подвал

Область = Макет. ПолучитьОбласть(«Подвал»);

Область. Параметры. КоличествоЧасов = КоличествоЧасов;

//Подсчет отсутствующих

ЗапросН = Новый Запрос;

ЗапросН. УстановитьПараметр(«Оценка1»,Перечисления. Оценки. Неявка );

ЗапросН. УстановитьПараметр(«Оценка2»,Перечисления. Оценки. Недопуск );

ЗапросН. УстановитьПараметр(«Ссылка»,ЭтотОбъект. Ссылка);

ТекстЗапросаН = «ВЫБРАТЬ ЭкзаменационнаяВедомостьТабличнаяЧасть1.Оценка

|ИЗ Документ. ЭкзаменационнаяВедомость. ТабличнаяЧасть1 КАК ЭкзаменационнаяВедомостьТабличнаяЧасть1

|ЛЕВОЕ СОЕДИНЕНИЕ Документ. ЭкзаменационнаяВедомость КАК ЭкзаменационнаяВедомость1

|ПО ЭкзаменационнаяВедомостьТабличнаяЧасть1.Ссылка = ЭкзаменационнаяВедомость1.Ссылка

|ГДЕ (ЭкзаменационнаяВедомостьТабличнаяЧасть1.Оценка = &Оценка1

|ИЛИ ЭкзаменационнаяВедомостьТабличнаяЧасть1.Оценка = &Оценка2)

|И ЭкзаменационнаяВедомость1.Ссылка = &Ссылка» ;

ЗапросН. Текст = ТекстЗапросаН;

Область. Параметры. Неявка = ЗапросН. Выполнить().Выбрать().Количество();

//Подсчет оценок

ТекстЗапроса = «ВЫБРАТЬ ЭкзаменационнаяВедомостьТабличнаяЧасть1.Оценка

|ИЗ Документ. ЭкзаменационнаяВедомость. ТабличнаяЧасть1 КАК ЭкзаменационнаяВедомостьТабличнаяЧасть1

|ЛЕВОЕ СОЕДИНЕНИЕ Документ. ЭкзаменационнаяВедомость КАК ЭкзаменационнаяВедомость1

|ПО ЭкзаменационнаяВедомостьТабличнаяЧасть1.Ссылка = ЭкзаменационнаяВедомость1.Ссылка

|ГДЕ ЭкзаменационнаяВедомость1.Ссылка = &Ссылка

|И ЭкзаменационнаяВедомостьТабличнаяЧасть1.Оценка = &Оценка» ;

//Подсчет 5(отл)

Запрос5 = Новый Запрос;

Запрос5.УстановитьПараметр(«Оценка»,Перечисления. Оценки. Отлично );

Запрос5.УстановитьПараметр(«Ссылка»,ЭтотОбъект. Ссылка);

Запрос5.Текст = ТекстЗапроса;

Область. Параметры. Отлично = Запрос5.Выполнить().Выбрать().Количество();

//Подсчет 4(хор)

Запрос4 = Новый Запрос;

Запрос4.УстановитьПараметр(«Оценка»,Перечисления. Оценки. Хорошо );

Запрос4.УстановитьПараметр(«Ссылка»,ЭтотОбъект. Ссылка);

Запрос4.Текст = ТекстЗапроса;

Область. Параметры. Хорошо = Запрос4.Выполнить().Выбрать().Количество();

//Подсчет 3(удов)

Запрос3 = Новый Запрос;

Запрос3.УстановитьПараметр(«Оценка»,Перечисления. Оценки. Удовлетворительно);

Запрос3.УстановитьПараметр(«Ссылка»,ЭтотОбъект. Ссылка);

Запрос3.Текст = ТекстЗапроса;

Область. Параметры. Удовл = Запрос3.Выполнить().Выбрать().Количество();

//Подсчет 2(неуд)

Запрос2 = Новый Запрос;

Запрос2.УстановитьПараметр(«Оценка»,Перечисления. Оценки. Неудовлетворительно );

Запрос2.УстановитьПараметр(«Ссылка»,ЭтотОбъект. Ссылка);

Запрос2.Текст = ТекстЗапроса;

Область. Параметры. Неуд = Запрос2.Выполнить().Выбрать().Количество();

//Декан

Область. Параметры. Декан = Константы. Декан. Получить();

ТабДок. ОриентацияСтраницы = ОриентацияСтраницы. Портрет;

ТабДок. Вывести(Область);

ТабДок. ОтображатьСетку = Ложь;

ТабДок. Защита = Ложь;

ТабДок. ТолькоПросмотр = Ложь;

ТабДок. ОтображатьЗаголовки = Ложь;

ТабДок. Показать();

//}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ

КонецПроцедуры

Печатная форма документа «Экзаменационная ведомость»

Печатная форма документа «Ведомость курсовых работ»

Печатная форма документа «Зачетная ведомость»

Приложение 2

Текст процедуры обработки проведения документа «Экзаменационная ведомость»

Процедура ОбработкаПроведения(Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл

// регистр Успеваемость

Движение = Движения. Успеваемость. Добавить();

Движение. Студент = ТекСтрокаТабличнаяЧасть1.ФИОСтудента;

Движение. Дисциплина = Дисциплина;

Движение. Преподаватель = Преподаватель;

Движение. Группа = Группа;

Движение. Год = Год;

Движение. Семестр = Семестр;

Движение. ФормаКонтроля = Перечисления. ФормаКонтроля. Экзамен;

Движение. Оценка = ТекСтрокаТабличнаяЧасть1.Оценка;

Движение. КолЧасов = КоличествоЧасов;

КонецЦикла;

// записываем движения регистров

Движения. Успеваемость. Записать();

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Текст процедуры обработки проведения документа «Ведомость курсовых работ»

Процедура ОбработкаПроведения(Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл

// регистр Успеваемость

Движение = Движения. Успеваемость. Добавить();

Движение. Студент = ТекСтрокаТабличнаяЧасть1.ФИОСтудента;

Движение. Дисциплина = Дисциплина;

Движение. Преподаватель = ТекСтрокаТабличнаяЧасть1.Преподаватель;

Движение. Группа = Группа;

Движение. Год = Год;

Движение. Семестр = Семестр;

Движение. ФормаКонтроля = Перечисления. ФормаКонтроля. КурсоваяРабота;

Движение. Оценка = ТекСтрокаТабличнаяЧасть1.Оценка;

КонецЦикла;

// записываем движения регистров

Движения. Успеваемость. Записать();

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Текст процедуры обработки проведения документа «Зачетная ведомость»

Процедура ОбработкаПроведения(Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл

// регистр Успеваемость

Движение = Движения. Успеваемость. Добавить();

Движение. Студент = ТекСтрокаТабличнаяЧасть1.ФИОСтудента;

Движение. Дисциплина = Дисциплина;

Движение. Преподаватель = Преподаватель;

Движение. Группа = Группа;

Движение. Год = Год;

Движение. Семестр = Семестр;

Движение. ФормаКонтроля = Перечисления. ФормаКонтроля. Зачет;

Движение. Оценка = ТекСтрокаТабличнаяЧасть1.Отметка;

Движение. КолЧасов = КоличествоЧасов;

КонецЦикла;

// записываем движения регистров

Движения. Успеваемость. Записать();

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Текст процедуры обработки проведения документа «Ввод академической разницы»

Процедура ОбработкаПроведения(Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл

// регистр Успеваемость

Движение = Движения. Успеваемость. Добавить();

Движение. Студент = ФИОСтудента;

Движение. Дисциплина = ТекСтрокаТабличнаяЧасть1.Дисциплина;

Движение. ФормаКонтроля = ТекСтрокаТабличнаяЧасть1.ФормаКонтроля;

Движение. Оценка = ТекСтрокаТабличнаяЧасть1.Оценка;

Движение. КолЧасов = ТекСтрокаТабличнаяЧасть1.КолЧасов;

КонецЦикла;

// записываем движения регистров

Движения. Успеваемость. Записать();

// КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Если вы думаете скопировать часть этой работы в свою, то имейте ввиду, что этим вы только снизите уникальность своей работы! Если вы хотите получить уникальную курсовую работу, то вам нужно либо написать её своими словами, либо заказать её написание опытному автору:
УЗНАТЬ СТОИМОСТЬ ИЛИ ЗАКАЗАТЬ »